23072 素数个数

题目描述

编程求 ( 为大于2的正整数)中有多少个素数。

输入格式

输入

输出格式

素数个数

样例

样例输入

10
样例输出

4
数据范围与提示 分类标签

[函数]

C++题解代码

#include <bits/stdc++.h>
using namespace std;

int a;
int c;
int b;


bool fn2(int y) {
  c = sqrt(y);
  for (int j = 2; j <= c; j++) {
    if ((y%j) == 0) {
      return false;
    }
  }
  return true;
}

// The main procedure
int main() {
  cin>>a;
  b = 0;
  for (int i = 2; i <= a; i++) {
    if (fn2(i)) {
      b++;
    }
  }
  cout<<b;
  return 0;
}

Blockly题解代码图片