20027 吃瓜群众

题目描述

群众想要吃瓜,于是给你一个瓜让你切,但是作为考验 告诉你西瓜的重量,问你能否将这个西瓜分成两部分,每个部分都是偶数。

输入格式

输入一行,包含一个整数weight,表示西瓜的重量1 <= weight <= 100

输出格式

输出一行,见样例。

如果可以输出: YES, you can divide the watermelon into two even parts.

如果不可以则输出: NO, you can't divide the watermelon into two even parts.

样例

样例输入

8
样例输出

YES, you can divide the watermelon into two even parts.
数据范围与提示

要注意检查你的输出格式要跟样例输出一模一样才能通过,尤其别忘了句子最后的小点哦

hint:并不要求切成两部分一样大的哦。

分类标签

[语法基础]

C++题解代码

#include <bits/stdc++.h>
using namespace std;

int a;


// The main procedure
int main() {
  cin>>a;
  a = (a-2);
  if (((a%2) == 0) && (a > 0)) {
    cout<<"YES, you can divide the watermelon into two even parts.";
  } else {
    cout<<"NO, you can\'t divide the watermelon into two even parts.";
  }
  return 0;
}

Blockly题解代码图片